
Camera EI3 Extender Board Support 
Package (BSP) v1.1.0 Release Notes 

These release notes subsume the release notes for previous updates. Release notes for previous 
updates can be found at the end of this document. 

Release 1.1.0 requires CrossCore Embedded Studio (CCES)  Release version 1.1.0. The download link 
can be found in the "Product Downloads" section at www.analog.com/cces . 

Release Dependencies 

 Requires CrossCore Embedded Studio (CCES) Release version 1.1.0 

     Requires the following BSPs for running the Camera EI3 BSP examples. 

 Requires Video Encoder EI3 Extender BSP version 1.1.0 

 Requires WVGA/LCD EI3 Extender BSP version 1.1.0 

This release was tested with: 

 ADSP-BF609 EZ-Board Rev 1.0 BOM Rev 1.4, for more information please 
visit www.analog.com/BF609EZBoard. 

 ADSP-BF707 EZ-Board Rev 1.0 BOM Rev 1.4, for more information please 
visit http://www.analog.com/en/processors-dsp/blackfin/ADSP-BF707/products/EVAL-
BF707/eb.html. 

 Video Encoder EI3 Extender Rev 1.0 BOM Rev 1.1, for more information please 
visit http://www.analog.com/en/evaluation/eval-bfext-videi3/eb.html. 

 WVGA/LCD EI3 Extender Rev 1.1 BOM Rev 1.3, for more information please 
visit www.analog.com/ei3-lcd 

 Camera EI3 Extender Rev 1.0 BOM Rev 1.1,  for more information please 
visit  www.analog.com/EX3-Camera. 

 MT9M114 Demo Headboard Revison 2, for more information please visit http://www.aptina.com/ 

 MT9V024 Demo Headboard Revision 1R , for more information please 
visit http://www.aptina.com/ 

  

New features and examples in this release 

 Added support for ADSP-BF707 processor. 

 Added video class driver support for MT9M114 sensor. 

 Added Frame Capture to file examples for ADSP-BF707 processor. 

Documentation 

The API documentation for MT9V024 and MT9M114 drivers can be found in CCES Help under: 

       Camera EI3 Extender Board Support Package 1.1.0  
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Video class driver documentation can be found in CCES Help under:  
      CrossCore® Embedded Studio 1.1.0 > System Run-Time Documentation > System Services and 
Device Drivers > Audio and Video Class Driver API Reference   

Software issues addressed in this release 

None. 

Upgrading Projects to use New Version of the Add-Ins 

Projects that currently use version 1.0.1 of the Add-Ins need to be upgraded to use version 1.1.0. In 
CCES Project Explorer window, select the project and click on 'system.svc'.  In the 'Overview' tab, review 
all Add-Ins and click on the 'Upgrade' button.  For dual-core projects, system.svc must be reviewed for 
each core. 

Known issues 

None 

  

Camera EI3 Extender Board Support 
Package (BSP) v1.0.1 Release Notes 

Thank you for installing the Camera EI3 Extender Board Support Package (BSP). The BSP provides 
software and documentation in support of the Camera EI3 Extender Board. 

The Camera EI3 Extender Board connects to an Analog Devices EZ-Board by means of the Expansion 
Interface 3 (EI3) interface. The EZ-Board is designed for use with CrossCore® Embedded Studio (CCES) 
for Analog Devices Processors software development tools. The CCES development environment aids 
advanced application code development and debug, such as: 

 Create, compile, assemble, and link application programs written in C++, C, and assembly 

 Load, run, step, halt, and set breakpoints in application programs 

 Read and write data and program memory 

 Read and write core and peripheral registers 

 Plot memory 

For more details on CCES, please visit www.analog.com/cces.  

For more information on the Camera EI3  Extender Board, please visit  www.analog.com/EX3-Camera. 

For more information on the ADSP-BF609 EZ-Board, please visit www.analog.com/BF609EZBoard. 

  
The Camera EI3 Extender BSP provides comprehensive software support for the Camera EI3 Extender 
Board. Specifically, drivers, examples and code sketches are included for the following components: 
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 MT9V024 Aptina sensor. 

 MT9M114 Aptina sensor. 

The CCES Help environment provides complete hardware and software documentation. 

Installation Logging 

The installer does not create a log file by default. If you encounter installation issues, you can generate an 
installation log file by running the installer from the command prompt. 

Change to the directory containing downloaded installer executable and run the following from the 
command prompt: 

 ADI_Camera_EI3_Extender_Board-Rel1.0.2.exe /v"/l*v c:\temp\installer.log" 

Support and Assistance 

There are several options for contacting support: 

 Submit your questions online at:  

http://www.analog.com/support 

 E-mail your Processor and DSP software and development tools questions from within 
CrossCore Embedded Studio: 

Go to “Help->E-mail Support…”. This will create a new e-mail addressed 
to processor.tools.support@analog.com, and will automatically attach your CrossCore 
Embedded Studio version information (ProductInfo.html). 

 E-mail your Processors and DSP applications and processor questions to:  
o processor.support@analog.com OR 
o processor.china@analog.com (Greater China support) 

 Post your questions in the Processors and DSP online technical support community in Engineer 
Zone at:  

http://ez.analog.com/community/dsp 

Supported Processors 

Although the Camera EI3 Extender is designed to work with any EZ-Board that supports the Expansion 
Interface 3, this release of the BSP supports only the ADSP-BF60x family of Blackfin processors. 

Software Requirements 

To build the example projects included in the Camera EI3 Extender Board BSP the following packages 
are required: 
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 CrossCore Embedded Studio version 1.0.2 or later. 

 WVGA/LCD EI3 Extender Board support package version 1.0.1 or later.  

 Video Encoder EI3 Extender Board support package version 1.0.1 or later. 

Test Configurations 

The software versions used to test are: 

1.0.2 CCES with 1.0.1 WVGA/LCD EI3 Extender BSP and 1.0.0 Video Encoder EI3 Extender BSP 

At the time of release, the tested hardware revisions are: 

 ADSP-BF609 EZ-Board PCB Revision 1.0 BOM Revision 1.2 

 WVGA/LCD EI3 Extender Board PCB Revision 1.0 BOM Revision 1.2 

 Video Encoder EI3 Extender Board PCB Revision 1.0 BOM Revision 1.0 

 Camera EI3 Extender Board PCB Revision 0.1 BOM Revision 1.0 

 MT9M114 Demo Headboard Revison 2 

 MT9V024 Demo Headboard Revision 1R  

Getting Started 

Adding a Driver to a Project 

When adding a Camera EI3 Driver to your project, the IDE will add the sources for the driver to the CCES 
Project folders, starting  at "system/Camera_EI3". There will be a folder specific to the driver(s) you have 
added under this folder.  

Creating a project which includes an Camera EI3 driver 

In order to create a project you should follow the instructions provided in the CrossCore Embedded 
Studio help. As part of the project creation, the page "Add-in selection" contains a list of all the available 
add-ins for the project that you are creating based on the installed products and the project's chosen 
processor and type. You can see the drivers in support of the Camera EI3 under the "Device Drivers and 
System Services" category. Within this category you will see "Camera EI3 Extender Board Drivers". 

The Camera EI3 add-in generates a call to adi_initComponents().  For more information on 
adi_initComponents(), please refer to the CCES help section: 

CrossCore® Embedded Studio 1.0.2 > Graphical Development Environment > System Configuration   

Adding a Camera EI3 driver to an existing project 

Every CrossCore Embedded Studio project contains a System Configuration file 

called system.svc which is located in the root of the project. The file is the IDE's interface for managing 

the various pre-written software components used in the "system" implemented by a project. Double-

clicking any system.svc file in a navigation view opens that file in the System Configuration Utility 

which allows you to see the add-ins that you currently have in your project. Click on "Add..." and 
select the Sensor (MT9V024) or Sensor (MT9M114)  driver from the Camera EI3 Extender Board Drivers 
add-in which is under the "Device Drivers and System Services". 



Notes: 

 If the IDE detects that adi_initComponents() is not yet present in main(), it prompts you to 

add it and offers to insert it for you. 

Configuration 

There are no Camera EI3 driver configuration options available in the IDE. 

Interrupts  

CrossCore Embedded Studio provides a coherent interrupt management mechanism which allows for the 
same interface to be used in RTOS and non-RTOS applications. This means that interrupt service 
routines in all applications must be written in C and use the adi_int interface. Any thread-safety 
requirements or interactions with tasks are handled by the adi_int interface. For more information on the 
adi_int API, in CrossCore Embedded Studio go to Help > Search and enter adi_int. 

Examples of the usage of this interrupt management mechanism are the System Services and Device 
Drivers provided with Crosscore Embedded Studio. By using the adi_int interface, the same services and 
drivers can be used in all applications regardless of whether an operating system is used. 

Sketches and Examples 

Sketches 

CrossCore Embedded Studio provides a mechanism by which small code fragments, called sketches, can 
be generated with parameterized input provided by the user. The resulting code can then be copied and 
pasted to a project. Camera EI3 BSP related sketches are provided. To locate the sketches specific to 
the Camera EI3 Extender BSP, open up the example browser  (Help -> Browse Examples) and then 
select Camera EI3 Extender Board product in the "Product:" pulldown. 

Examples 

In addition to the code sketches, the Camera EI3 Extender BSP provides examples which show how to 
use each of the drivers included in the BSP.  

The following examples are available in this release:  (For more information on the examples see 
the README file.) 

1. Videoloopback from MT9V024 sensor to LCD. 
2. FrameCapture from MT9V024 sensor to LCD. 
3. VideoLoopbackYUV from MT9M114 sensor to Video Encoder. 
4. VideoLoopbackYUV from MT9M114 sensor to Video Encoder using video class driver. 
5. VideoLoopbackRGB from MT9M114 sensor to LCD. 

Note: 

 The Videoloopback, FrameCapture, VideoLoopbackRGB examples requires WVGA/LCD EI3 
Extender board and its corresponding BSP. 

 The VideoLoopbackYUV example requires Video Encoder EI3 Extender Board and its 
corresponding BSP. 



Location 

In order to locate the Camera EI3 Extender BSP examples and sketches, you can use the following: 

 Open CrossCore Embedded Studio's Example Browser which can be found in CrossCore 
Embedded Studio under Help. Select in the Product section "Camera EI3 Extender Board 
v1.0.0" for a full list of examples and sketches. 

Documentation 

Hardware Manual and API documentation for the drivers included in the Camera EI3 Extender BSP can 
be found in CCES Help.  

General information on the driver model can be found in CCES help under  
   
    CrossCore ® Embedded Studio 1.0.2 > System Runtime Documentation > System Services and 
Device Drivers  
    
    

Integration with CrossCore Embedded 
Studio 

System View 

CrossCore Embedded Studio provides the System View which is used by the Camera EI3 Extender BSP. 
Use the System Configuration Overview tab to add Camera EI3 Extender BSP driver sources into 
a CrossCore Embedded Studio project. 

To access the System Configuration Overview tab, do one of the following: 

 In a navigation view, double-click the system.svc file of a project. The System Configuration 

utility appears with the overview tab selected. 

 If the utility is already open, select the Overview tab. 

As well as being able to add, remove and upgrade add-ins from this window, you will also be provided a 
list of examples and sketches associated with the selected add-in. 

For more information about the System Configuration utility, see the CrossCore Embedded Studio help. 

  

MISRA-C Support 

MISRA C is a software development standard for the C programming language developed by the Motor 
Industry Software Reliability Association (MISRA). Its aims are to facilitate code safety, portability, and 



reliability in the context of embedded systems, specifically those systems programmed in ANSI C. The 
compiler detects violations of the MISRA rules at compile-time, link-time, and run-time.   

System Services and Device Driver Thread Safety 

All system services and device drivers (SSDD) use mutexes and semaphores to ensure thread-safety. If 
an RTOS is present then the SSDD will use the RTOS mutex and semaphores. If an RTOS is not present 
then the SSDD will use a non-RTOS implementation of mutexes and semaphores (spin locks). 

Known issues with the Camera EI3 Extender Board  
Support Package (BSP) 

1. The VideoLoopback example does not work in real time. The update of the LCD screen may take 
several seconds after scene change pointed by the camera. This is due to the software based 
color conversion from Bayer to RGB required for displaying the output image from the sensor. 
The software based algorithm is currently not optimized. An optimized version of the algorithm will 
be added in the future releases of the Camera EI3 BSP. 

2. The FrameCapture example can display a distorted image if the frame is captured when the 
subject is in motion. 

3. The Camera extender card supports 8, 10 and 12 bit interfaces, but currently the BSP supports 
only 8bit (MT9M114) and 10bit sensor (MT9V024). 

4. The MT9V024 and MT9M114 drivers only support parallel output mode.   
5. Occasionally the screen will remain white and the executable will not exit.       
6. Removing an Add-in component from a project and building the project may result in a build error, 

as the underlying Makefile dependencies have not been re-generated. If a build error is 
encountered, clean the project (Project > Clean) before trying to build the project again.    

7. After opening an example via the Example Browser (Help > Browse Examples), semantic errors 
may be listed in the Problems View (Window > Show View > Problems). Some of these errors 
may not be real errors and may be misleading. To clean-up the problems listed: 

 Right-click on your project and select Index > Rebuild 

 Right-click on your project and select Index > Update with Modified Files 

  Or 

 Right-click on your project and Close Project 

 Right-click on your project and Open Project 

  

  

   

  

   

  



  

  


